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MIGRATING FROM ALTIUM DESIGNER TO PADS PROFESSIONAL
PADS solves the PCB design problems that other desktop tools can't.

The challenges of electronic product design have changed a lot over the years, and they will 
continue to change well into the future. 

As an engineer or PCB designer using Altium , you know those issues very well. You also know 
where your current tools could do more. 

Think about the design challenges you’re faced with today. Can you be sure your products will 
function as designed without spending a lot of time and money on prototypes and respins? 
Can you ensure right-first-time design without simulation? Can layers of buried commands 
provide easy access to design-specific tasks?

Only PADS® provides engineers and small teams with a product creation platform optimized 
for component selection, signal and power integrity, electronics cooling, form and fit, PCB 
layout, and manufacturing.

OUR HISTORY
Our goal of bringing superior PCB design technology to individual engineers has never 
changed. From the earliest days of PCB design automation, PADS has led the market: 

•	 First PCB layout tool to focus on ease of use

•	 First to implement advanced auto-placement tools in a ready-to-use integrated PCB 
desktop design solution

•	 First on Windows NT 

•	 First to implement conditional rules 

•	 First any-angle autorouter 

•	 First to implement high-speed geometric checking  

•	 First to recognize the importance of powerful, easy-to-use signal analysis 

•	 First to introduce advanced packaging capabilities 

•	 First Computer Integrated Design (CID) platform for software development
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YOUR FUTURE
But PADS isn’t about history. It’s about helping innovators like you create the very best electronic 
products possible. With the PADS Product Creation Platform, engineers and small teams can 
solve the problems of modern-day PCB design at incredibly affordable prices. 

With PADS you can:

•	 Reduce validation and debug cycles for PCBs that use DDR memory

•	 Discover unexpected or unpredictable SI and EMC issues prior to fabrication

•	 Combine automatic and interactive routing to route dense and highly constrained 
boards up to 30X faster than with manual routing alone

•	 Improve product reliability and circuit performance by solving crosstalk, termination, 
timing, and other common SI problems before layout

•	 Prevent IC malfunctions and optimize power delivery networks (PDNs) using quick 
voltage-drop simulation and analysis of power supply rails

•	 Model and resolve conduction, convection, and radiation issues before fabrication to 
ensure product reliability

•	 Avoid production delays by using more than 100 fabrication and assembly analyses to 
detect and resolve issues before they get to manufacturing

•	 Fit complex electronics into their enclosures using collaborative ECAD-MCAD 
methodologies that work with any MCAD tool.

GETTING STARTED 
Use the steps in this guide to bring Altium Designer projects into PADS Professional. Included 
are instructions for creating a central library, translating cells into that library, creating a 
new project in PADS, importing your schematic, running the translator, and packaging and 
synchronizing your design. 

Online training, including 30 days’ free access to select topics, will fast-track your learning 
curve and have you up and running fast. 

We hope you’ll enjoy working with PADS as much as we enjoy developing scalable, product-
creation technology for innovators, designers, and engineers like you. Contact a PADS Product 
Creation specialist to learn more.

https://learn.mentor.com/library/pads-professional-training-library/5d9e213
http://www.pads.com/buy
http://www.pads.com/buy
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ALTIUM TO PADS PROFESSIONAL TRANSLATION

This document describes the process of translating an Altium Designer design (*.SchDoc and 
*.PcbDoc files) to PADS Professional VX.2 (PADS DX Designer/PADS Professional Layout flow).

The translation process can be summarized as follows:

•	 Sync Altium Design. Compose list of component properties to be removed, aliased, or 
that may contain illegal characters

•	 Create new PADS DX Designer project and a library

•	 Run Altium layout translator on temporary project in order to populate library with cells 
and padstacks

•	 Create a new PADS DX Designer project that points to the library created

•	 Import Altium schematic into PADS DX Designer

•	 Translate Altium layout, adding the new PCB to the project

•	 Package PADS DX Designer schematic

•	 Launch PADS Professional Layout and Forward Annotate

The process may include additional manual steps to fix schematic, layout, or library data 
caused by flow differences between Altium Designer and PADS Professional.

•	 The following files are needed for an Altium Design translation: *.PcbDoc, *.SchDoc, 
*.PrjPcb

•	 PADS Professional VX.2 flow must be installed (make sure to install Schematic 
Translators).

•	 If PADSProVX.2 is not the active flow, use Start ► All Programs ► Mentor Graphics PCB 
► MGC PCB Release Switcher, to configure PADSProVX.2 as the active flow.
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Overview and Background

•	 What data do you end up with in the PADS Professional flow:

•	 PADS DX Designer schematic project directory 

•	 PADS DX Designer PRJ file

•	 PADS Professional PCB file

•	 	A central library is an indexed library structure that includes, symbol, cells/
decals/footprints, and padstacks that make up decals.

•	 	Objects are grouped in similar partitions. For example all discrete symbols into the 
discrete partition. 

•	 	The Central library also defines allowable properties for use in schematic and 
Layout. 

•	 	Part information is stored in the central library including the symbol, footprint, and 
pin mapping. Parts use a unique identifier Part Number. 

•	 Symbol property differences between products. 

Configure initial mapping in altium.cnv during Altium to PADS Netlist Schematic Translation 
(The default configuration will be fine, unless the Altium design uses custom properties.)

Altium PADS Netlist  PADS integrated
Pin Number # Pin Number

Design Item ID DEVICE Part Number

PCB Footprint PKG_TYPE Cell Name

Designator REFDES Ref Designator

•	 Ini settings files for translation

•	 alt2pads.ini (Mounting Hole configuration for layout translator for Altium designs)

•	 ppcb2hkp.ini (Mounting Hole configuration for layout translator for Altium designs)

•	 altium.cnv PADS DX Designer Altium translator (Illegal character and property 
mapping) 

Appendix A: Create ini files for proper Mounting Hole migration into the Library
Appendix B: Schematic translator configuration files
Appendix C: Importing unlinked Altium Schematic files
Appendix D: Common issues
Appendix E: Retargeting a translated design to work with the corporate library
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CREATE NEW CENTRAL LIBRARY

In this step, a central library is created for storing the symbols and parts translated from the Altium 
schematic. First, the library will be updated with cells and pad stacks created by the Altium 
layout translator, then the schematic translation process will bring over parts and symbols. 
Cells must be first imported into the central library or the library may become corrupted and 
the translation will fail. Please follow the instructions exactly as written. If the Altium design 
contains part decals/cells that contain mounting holes, follow Appendix A: Create ini files for 
proper Mounting Hole migration into the Library 

•	 Open PADS DX Designer from ► All Programs ► PADS Professional VX.2 ► Design Entry ► PADS 
DX Designer 

•	 On the Start Page, select the PADS Professional icon in the Task / New Project section

•	 Under Available templates, select the PADS template

•	 Enter a Name for the new project

•	 Browse to the Location for the new PADS DX Designer project

•	 Create a Central Library by clicking on the Central Library icon and inputting the Central Library 
name

•	 Click the Create button

•	 Verify that the Library was created by Opening PADS Library Tools by clicking on Tools ► PADS 
Library Tools
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RUN ALTIUM PCB TRANSLATOR TO TRANSLATE CELLS INTO CENTRAL LIBRARY

In this step the Altium layout is run in order for the translator to add the design-specific cells 
(footprints) to the central library.

The translator creates a new PADS Layout in the project directory.  In this example, it is
C:\ALTIUM_TRANSLATION\ALTIUM_TO_PADS_PRO\USB_panel\PCB\Board1.pcb

The translator also updates the Central Library associated with the project, creating a new cell 
partition named the same as the PCB design (“Board1.pcb” in the example). Close the Altium 
to PADS Professional Translator. 

•	 Verify Cell and padstack data by opening the PADS DX Designer project file created 
then go to Tools ► PADS Library Tools to open the Central Library

•	 Review the Cell and Pad stack data

•	 Close the Central Library

•	 Launch the Altium PCB translator from 
Start ► PADS Professional VX.2 ► 
Translators► Altium PCB Translator VX.2.

•	 Select the Altium project file (.PcbDoc) 
to be translated.

•	 Select the tempory PADS DX Designer 
project file created in the sections 
above.

•	 Click the Translate button.
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CREATE A NEW PADS PROFESSIONAL PROJECT

In this step a new PADS DX Designer project will be created to become the translated design. 

At this point, a PADS DX Designer project is created with the library association.

•	 In PADS DX Designer VX.2 ► Setup ► Settings, change the Special Components, Border 
Symbols, and Bus Contents file pointers to point to empty local files. (if you are using a custom 
corporate project template skip this step)

•	 Invoke PADS DX Designer Using Start ► 
PADS Professional VX.2 ►Design Entry 
► PADS DX Designer VX.2

 •	 On the Start Page, select the PADS 
Professional icon in the Task / New 
Project section 

•	 Under Available templates select the 
PADS template 

For a guide to create your own project 
template (standard set of settings for all 
new designs), see MG580490

•	 Enter a Name for the new project 

•	 Browse to the Location for the new 
PADS DX Designer project

•	 Browse and choose the design-specific 
Central Library created in the previous 
section

•	 Click the Create button

https://supportnet.mentor.com/portal?do=reference.tutorial&id=MG580490
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Before:

After:	
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IMPORT ALTIUM SCHEMATIC

In this step we are translating the Altium schematic, and the library data associated with the 
design.

•	 In PADS DX Designer select File 
►Import ►Altium. This will open the 
Protel/Altium translator interface

•	 Select the Schematics tab

•	 Under Schematics to translate, select 
Add 

•	 Browse and select the Altium 
Designer PrjPcb 

Note. The PrjPcb links the Altium 
schematic files together. If only 
.SchDoc files are available, follow 
Appendix C: Importing unlinked 
Altium Schematic files

•	 Select Translate attributes.

•	 Unselect Translate symbols only 
(without the schematic).

•	 Select Create Design Library

•	 Unselect Create generic symbols.

•	 Select Use default color scheme

•	 Select the Settings tab
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In the COMPONENT ATTRIBUTES section: 

•	 Set the Property Mapping

•	 For more information on specific 
mappings, refer to the PADS DX 
Designer Altium translator’s specific 
documentation. The defaults should 
handle most cases.

•	 If any Altium Properties need to be 
removed, you can enter in a blank 
Value. In this example Package 
Information will be removed upon 
translation.

•	 You can also alias any properties. In this 
example, Package Reference is aliased 
to Manufacturing_Part_Number

In the CONVERSION section:

•	 Toggle on the CollectInstanceCells 
option

•	 Add a Partition Name to the 
PartitionName option

Note: PartitionName entry must start 
with an alpha character.

•	 Select the value field for 
UseTranslatedCentLib and navigate to 
and select the central library that was 
previously created 

•	 Unselect the Normalize Symbols setting 

•	 Return to the Schematic tab and push 
Translate. The translation summary is 
shown in the end of the process
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•	 Review the warnings and errors in the log file saved in the PADS DX Designer project LogFiles 
folder

At this point, the schematic is translated in PADS DX Designer, and the Central Library has been 
updated with part information.

Check Schematic Database Consistency

•	 In PADS DX Designer, open Tools ► Diagnostics. Review the results window for errors. If errors 
were found, select “Click here to fix all errors” at the end of the report. Run Diagnostics again 
to be sure the error was resolved. 
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RUN ALTIUM PCB TRANSLATOR

In this step the Altium layout is translated and the PADS DX Designer project file is updated to 
reference the new PCB layout.

•	 Launch the command window from Start► PADS Professional VX.2 ► Translators► 
Altium PCB Translator VX.2

•	 Select the Altium project file (.PcbDoc) to be translated 

•	 Select the PADS DX Designer project file created in the sections above.

•	 Click the Translate button 

The translator creates a new PADS Professional Layout in the project directory. In the 
example, it is C:\Translation\USB_PANEL_PADS_PRO\PCB\USB_PANEL_PADS_PRO.pcb

•	 In PADS Professional Layout, go to File ► File Viewer and review the 
AltiumToPADSProfessionalTranslation.log file.
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PACKAGE, AND SYNC THE DESIGN

Package

•	 Open the translated project in PADS 
DX Designer 

•	 Run Tools ► Package. Use the 
following options to package for 
the first time. Later on, you may use 
different options.

•	 When the Packager operation 
completes, Review any Errors, Failures, 
or Warnings.

•	 If Packager Fails, please review Appendix D: Common issues
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•	 DRC Connectivity Rules are also helpful to run in order to verify the connectivity. Tools 
► Verify
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Synchronize schematic and layout

•	 Open PADS Professional Layout from PADS DX 
Designer Tools ► PADS Professional Layout

•	 Select Yes to Forward Annotate

•	 Select Allow Alpha-only reference designators 
and Rebuild local library data, preserve locally 
built data. Unselect the Trace removal options.

•	 Select the Forward Annotation Required bubble

•	 Review the Forward Annotation.txt log if there 
are errors. Correct the errors until Forward 
Annotation is successful. Review Appendix D: 
Common issues

If Forward Annotation was successful, then run Back Annotation. 

This concludes the translation and synchronization process.
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APPENDIX A: CREATE INI FILES FOR PROPER MOUNTING HOLE MIGRATION 
INTO THE LIBRARY
If mounting holes are used in the Altium design, ini files must be edited to ensure that mounting 
holes are not created as pins. You must initially open and close the translators to generate the 
required ini files. 

NOTE: This only needs to be done once for any VX.2 install.

•	 Invoke a PCB Command window Using Start ► All Programs ► PADS Professional VX.2 
► Administrative Tools ► MGC PCB CMD VX.2.

•	 Type Alt2pads in the command window and select the Enter key.

•	 Close the Translator 

•	 Type ppcb2hkp in the command window and select the Enter key

•	 Set the source design format to be PADS Layout Designs and Libraries

•	 Open the translator and close it without entering anything.
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Edit the ini Files with Mounting Hole information

The information that needs to be added to the ini files is the mounting hole pin number prefix. 
There isn’t a standard prefix in Atium. Thus you will need to verify what mounting hole pin 
number prefix to use and edit the files accordingly. Not making these modifications to the ini 
file will result in the mounting holes becoming NC pins in the PDB. 

•	 alt2pads.ini (PADS Layout Translator) 

This file is located: “C:\MentorGraphics\PADSProVX.2\SDD_HOME\pads\win32\bin”. This file is 
currently not accessible via GUI and must be manually edited. 

[Protel Mounting Holes]
PinNumberPrefix=@@MH
DECAL_NAME1="PIN_NUMBER1",PIN_NUMBER2" 
DECAL_NAME2="PIN_NUMBER1",PIN_NUMBER2"

•	 ppcb2hkp.ini

The file is located: “C:\MentorGraphics\PADSProVX.2\SDD_HOME\pads\win32\bin”. This file is 
currently not accessible via GUI and must be manually edited.

[Mounting Holes]
PinNumberPrefix=@@MH
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APPENDIX B:  FILES SCHEMATIC TRANSLATOR CONFIGURATION 

Altium.cnv (Symbol & Schematic Translator: Protel/Altium Designer to PADS DX Designer 
Integrated

This file is located C:\MentorGraphics\PADSProVX.2\SDD_HOME\standard\cnv\altium_
dx.cnv and can be changed with the GUI. 

	

•	 Illegal characters:

•	 To minimize the chance of encountering problems, the recommended character 
set for all object names (identifiers) is A-Z, a-z, 0-9 and _ (underscore). These 
characters can be used consistently for all names without any problems. Using 
other characters increases the risk of encountering a problem due to various 
character restrictions in downstream tools, windows/Linux file names, SQL, parsing 
data with regular expressions, passing the names in command line arguments, 
accessing and modifying objects via automation. 

•	 Symbol partitions need to start with an alpha character

•	 Nets and Global power/ground “Tap” Symbols can use + and – 

•	 For an official list of non-supported character sets, please review

•	 PADS Library Tools Process Guide (Library, Object, and Library Partition 
Limitations)

•	 PADS DX Designer Reference Manual (Illegal Characters in Name Identifiers)
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APPENDIX C: IMPORTING UNLINKED ALTIUM SCHEMATIC FILES

Altium handles schematics differently than PADS DX Designer. With Altium Designer, each 
schematic sheet is stored as a separate file and sheets are bound together by a project 
(.PrjPcb) file. PADS DX Designer organizes schematics with multiple sheets as a single file.

To convert a multiple-sheet schematic design that doesn’t include a .PrjPcb file, select just the 
first Altium schematic sheet (.SchDoc) and translate it. Then, keeping the PADS DX Designer 
project opened, select and translate every additional sheet independently.

When importing a multiple-sheet schematic (more than one .SchDoc) that does not have 
a project file (PrjPcb ), all of the schematic sheets will become individual blocks by default. 
Particularly for a multiple-sheet, non-hierarchical schematic (like the example below), it is best 
to convert each block into a schematic sheet. Start with the highest-numbered sheet and 
work your way back to sheet 1. The last sheet imported will become the root schematic sheet.

•	 Right click on the last sheet imported and select Set as Root to set up the board. In this 
example it is the PAGE_1 block.

•	 Right-click and Rename the board and schematic items.
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•	 Open Setup ► Settings ► Navigator ► Sheets. Set Display Sheets option to Always. This 
makes the first sheet visible in the Navigator which is used to copy/paste the sheets.

•	 Go to Setup ► Settings ► Advanced. Turn on the Preserve Packaging info on Copy 
switch. Turn off Unique names on copy.
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•	 Select the OK button

•	 Expand the next block to show the sheet name

•	 Right-click and change the sheet name from “1” to “2”

•	 Right-click the sheet named “2” and copy and paste the sheet into the board 
schematic.

•	 Repeat this process until every schematic sheet is renamed and moved into the board 
schematic.

•	 Right-click and delete the blocks.
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APPENDIX D: COMMON ISSUES

Packaging Errors 

•	 Pin/Port name mismatch between parent block and child schematic. This pin not found in 
child block.

•	 Push into the offending block, the connectivity will automatically update. Verify the block 
symbol and underlying port connectivity match.

•	 ERROR: Inconsistent part data. Reference Designator “” is on more than one symbol

•	 In the DxDesigner schematic, find all instances of the REFDES reported in the message. 
Either the part numbers are inconsistent or missing. Correct the inconsistency or add the 
missing part numbers and rerun Packager. The message includes the UID of the conflicting 
components. If the parts should have different REFDES values, running Packager using the 
option: Repackage all symbols will reassign the REFDES values and eliminate the error.

•	 ERROR: Block, Page, Symbol $1I157: Cell Name ‘' is not a valid cell for Part Number ''.

•	 Verify the part definition has the correct cell mapped. Usually all that is needed is to add 
the alternative cell

 Forward Annotation Errors

•	 ERROR: No valid cells were found for Part Number "". Change the Part Number in the 
schematic, edit the Parts DB and add an existing cell name, or add a missing cell to the Cell 
DB. Then run Forward Annotate.

Packager should catch most errors, though you may run into error messages concerning Part 
and Cell mapping. Verify that the part and cell are defined correctly.

In the case below, the Part Definition was linked to an alternative cell that was renamed. 
Simply Deleting the Cell and assigning the renamed cell resolved the issue.
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APPENDIX E: RETARGETING A TRANSLATED DESIGN TO WORK WITH THE 
CORPORATE LIBRARY

•	 Open the schematic using PADS DX Designer

•	 Select a symbol

•	 Using the find command (binocular icon), enter the symbol name and select the FIND 
ALL button.
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•	 Select the Select Items button in the pop-up window

•	 Hover over one of the selected symbols and use the RMB to go to Replace Symbol/
Part

•	 Set the following switches
•	 Preserve “RefDesignator”

•	 Symbol Only for Replace 
part

•	 All open sheets for Replace 
selection in

•	 Merge (schematic value 
wins) for Properties and 
values
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•	 Go to PADS Databook and select the same Part View tab. Then find and select the 
same symbol in the library partition that it resides in.

•	 In some cases, the symbol name might be different. If you can’t find the exact symbol 
name, you will need to look in the part number tab to find the symbol that was used in the 
library for this part.

•	 Then go back to the Symbol View tab and find that symbol and select it.

•	 It will appear in the Replace selected symbol(s)/part(s) with window of the Replace Symbol 
GUI.

•	 Select the Replace button
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•	 In some instances, the symbols might be different (as in this case).

•	 Notice the square connect point on the pin of the new symbols.

•	 Make sure that the connections still exist before forward annotating

•	 Select the Net icon and drag from the connect point in either direction of the line or 
pin. This will reconnect all the connection on that net.

•	 NOTE that the replace symbol function removed the pin numbers from the single-pin 
connector symbols. This requires you to add the correct pin numbers back on the 
symbols manually before you run the packager.

•	 Repeat this process for every different symbol on the schematic.

•	 Run the Package command. Make sure that there are not any errors. You want a 
successful package.

•	 Open PADS professional and run a forward annotation in the Project Integration 
window.
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WHAT’S NEXT?
Congratulations on making the move to PADS Professional! Now that you’ve translated your 
design files into PADS, it’s time to take advantage of everything the PADS design flow has to 
offer. Many resources are available to get you started and help you along the way.

•	 Free training!
https://www.mentor.com/training/course_categories/pads

•	 On-demand training includes a FREE 30-day subscription to online videos and hands-on 
lab exercises. Start your course within minutes of completing your registration!

•	 Instructor-led training is available in our training centers or through our Live Online 
remote program. Private training, at your site or ours, is available by request. 

•	 Community
Join PADS customers, technical experts from the PADS product team, and others in this open, 
global community. 
https://communities.mentor.com/community/pcb/pads

•	 Have an idea for a product enhancement?
Influence the product development process by submitting an enhancement idea, or voting and 
commenting on ideas submitted by others in the ‘Mentor Ideas for PADS’ area.
https://communities.mentor.com/community/ideas/pads-ideas

•	 Need technical support? 
Our SupportNet website offers rapid, secure self-service access to Service Request 
management, release/patch downloads, Knowledge Base access, license reports, and more.
https://supportnet.mentor.com

•	 PADS Professional videos 
https://www.pads.com/multimedia/#?filter=9f94dd4d-e581-494f-a534-
fdee67144d1a&start=1&limit=9

•	 PADS Professional datasheets
https://www.pads.com/resources/#?filter=datasheet-type,9f94dd4d-e581-494f-a534-
fdee67144d1a&start=1&limit=9

•	 Want to talk?
Contact a PADS Product Creation specialist in your area. We’d love to hear from you!
https://www.pads.com/buy

https://www.mentor.com/training/course_categories/pads
https://communities.mentor.com/community/pcb/pads
https://communities.mentor.com/community/ideas/pads
https://supportnet.mentor.com
https://www.pads.com/multimedia
https://www.pads.com/resources
https://www.pads.com/buy
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